Join 34,000+ subscribers and receive articles from our blog about software quality, testing, QA and security.
 

Exploratory Session not appearing


#1

Hi,

In my template dropdown im only seeing the default ‘Test Case’ template.

From reading https://blog.gurock.com/testrail-5-2-unique-screenshot-case-template-exploratory-testing/ i got the impression that thre should be a ‘Exploratory Session’ template added as default also. But its not appearing, any idea what could be the issue?

Thanks.


#2

Hi there!

Thanks for your posting! For upgraded instances, TestRail wouldn’t change the templates and custom field configuration but you can simply add a new Exploratory Session template and two text fields call Mission and Goals and assign these fields to the templates.

Cheers,
Tobias


#3

Thanks for the reply.

See here I added ‘Exploratory Session’. I then added the ‘mission’ and ‘goals’ fields and applied them to this template. See:

But they are still not appearing when I select the ‘Exploratory Session’ template when creating a test case.

Any idea what could be wrong?

Thanks


#4

Here is what it looks like when creating a test case with the new template select:

There is no sign of the new templates.


#5

Hello!

The problem is that you haven’t assigned the correct fields to the new exploratory session template. You would need to edit your fields and assign them just to the template they should be part of.

I hope this helps!


#6

Thanks for your reply.

But I believe I have that already done. See my first screenshot above. The 2 new fields are appearing ‘Exploratory Session’ when editing the template.
Then see the second screenshot, the 2 new fields are not appearing.
So I have assigned the new fields to the new template?


#7

Got it :slight_smile:
I needed to click on ‘Project Option’ and add a row height, the default is null and it won’t show unless this is set.
Thanks again.


#8

Great to hear that it works now :slight_smile: Yep, the project assignments are required so TestRail knows to which projects a custom field should apply to:

http://docs.gurock.com/testrail-userguide/howto-fields#project_assignments

Cheers,
Tobias