Join 34,000+ subscribers and receive articles from our
blog about software quality, testing, QA and security.

Error on Push to JIRA Cloud


#1

Hello,

I am getting an error popup in Test Rail whenever I try to Push an issue to Jira. I also get the same error popup whenever I hover over a created Jira issue that is linked in Test Rail. The error says: “Plugin “Jira_REST” returned an error: Invalid user or password or insufficient permissions for the integration user (HTTP code 401). Please make sure to use your actual JIRA username for the integration (not your email address, for example).” Here is a screenshot:

I have configured Jira integration in the Test Rail Admin…Integration section:

Do you have any idea how I can get around this? I can’t enable debug in TestRail since I am using the hosted edition. Jira Cloud version is 5.2.


#2

Hi Jeff,

Thanks for your posting! A 401 is an authentication related issue and this is likely caused by an invalid username and/or password. Can you please double check and re-enter the username and password you use for the integration?

Cheers,
Tobias


#3

Have done this several times but the error still occurs. Can we turn on debug logging so we can see more info? I can reproduce the issue quite easily.


#4

Hi Jeff,

Sure, do you use a Cloud instance or a local installation? If you host TestRail yourself, you can enable debug logging as follows:

http://docs.gurock.com/testrail-faq/system-debug

If you use TestRail Cloud instead, please send a quick email to contact@gurock.com so we can enable debug logging for your instance.

Cheers,
Tobias


#5

Hi @JavaJeff,

Did you find a solution to this? We’re running into the same issue after switching from on-premise Jira to cloud Jira. When clicking on the Jira link, the correct item in Jira is opened in a new tab, however, when hovering over it doesn’t show the preview like previously when connecting to the on-premise Jira. I’m seeing the same error you posted.

image

Thanks,
Erin