Join 34,000+ subscribers and receive articles from our
blog about software quality, testing, QA and security.

Error on push - Testrail & Jira Cloud


#1

hey

Trying Testrail out with Jira integration, but without success

I get the following error when i click on Push

Plugin “Jira_REST” returned an error: Invalid HTTP code (400). Please verify the address of your JIRA installation in the configuration settings and that TestRail can reach your JIRA server.

User name and PW is correct
API is enabled

Have the possebility to Add a bug from TestRail, but cannot Push


#2

Hi there,

Thank you for the posting. In the case of a REST API with a JSON payload, 400’s are typically, and correctly I would say, used to indicate that the JSON is invalid in some way according to the API specification for the service. That being said, could you possibly post your API request? Additionally, can you try passing this as a simple CURL request to the TestRail API as well to see if it accepts your request?


#3

Hi
thanks for your reply
We manage to solve it by typing in the username and pw for each user


#4

Hi Sbd,

Thanks for the update! Yes, the 400 error on the push defect dialog is usually related to a permissions issue in JIRA or a username/password issue. Updating the username/password in the Settings tab of your My Settings page would ensure each user is linked to the correct user in JIRA so that the integration knows what permissions to use. Glad to hear that you were able to find and get this fixed!

Regards,
Marco