Join 34,000+ subscribers and receive articles from our blog about software quality, testing, QA and security.
 

Emailing of Reports?


#1

Hi TestRail Folks!
This is most likely 99% user failure.
I successfully developed a Comparison for Cases report and I verified by checking ‘Myself Only’ and checking ‘Right now’ for Create this report. So far so good. Now I want to send this as a scheduled report to myself and others. However, I am not getting this scheduled report, nor are others. Here is what I did to change this private report:

  1. Opened report and clicked on ‘Create Similar’
  2. “This report can be accessed by:” Everyone
  3. “Create this report:” Scheduled this report: Every day, 08:00
  4. Checked OFF, “Right Now”
  5. Checked ‘Notify me by email’
  6. Checked ‘Email a link to the report’ and selected specific users as well as myself (using Ctrl-Click)
  7. Checked ‘Email the report as attachment’ and entered my valid email address

I have set my time zones, languages, etc., specifically to my locale (Pacific Time Zone, etc). I also have notify me by emails turned on also.

Why do you think I am not getting my scheduled reports, or anyone else for that matter.


#2

Hi!

Thanks for your posting. Do you have a self-hosted TestRail installation or do you use TestRail Cloud? If you use a self-hosted installation, you can test your email settings under Administration > Site Settings > Email. Also, are the actual reports generated and do they appear in TestRail’s UI on the Reports tab? If not, then it’s likely that your background task is not running and you can configure the task as follows:

http://docs.gurock.com/testrail-admin/howto-background-task

If you use a TestRail Cloud instance, could you please check if you see any of these email in your spam folder maybe? If so, it would be great if you or your IT could add @testrail.com and @gurock.com to your whitelist.

I hope this helps!

Cheers,
Tobias


#3

Hi Tobias,
You solved my problem and thank you. We are self-hosted and I found that the email user and password fields in site settings -> Email were filled in with defunct credentials. Clearing these fields solved the issue. Thanks again for pointing me in the right direction (yet again).

– Tom


#4

Thanks for your reply, Tom, and great to hear that it works now :smile:

Cheers,
Tobias