Join 34,000+ subscribers and receive articles from our
blog about software quality, testing, QA and security.

Email test report not receiving by external person (No TestRail Access)


#1

Hi,

New user of TestRail. I have tried sending a test report to an external person however, he is not receiving the email. I am not sure if there something that needs to be configured. I only ticked the check box “Email the report as attachment (no TestRail access required)” then input the email address.

Note: Already checked the Spam mail but to no avail.

Let me know if I missed something. Thanks!

Kayle


#2

The 3rd person may have rules in their email that prevents zip files from being delivered. They might get an error message but it is likely a config issue for the 3rd person. To test this send yourself a report (if your work allows zip files) and if you get the email and file then the issue is a config issue for the 3rd persons email…


#3

Thanks. The 3rd person is using Gmail as provider and I have read that it restricts zip files only if it contains executable file types or it is encrypted. Does the zip file from the report on TestRail contain those aforementioned?


#4

I believe the files are HTML files - not sure if they are considered executable though.

I just sent myself a report and there are .js files so those I believe are executable java files and that is probably causing the issue.


#5

Thanks again! I will check if there’s something we can do to unblock receiving those kinds of attachment.


#6

Glad to help - good luck… :wink:


#7

I am seeing the same issue, while sending the test report for external person, I tried both personnel email and work email, none of received the email.

Can please anyone help how to send the report or is this a bug?


#8

Have you had the 3rd party see if the zip files with executables are being blocked on their email server?


#9

I used my personnel gmail to send the report too and I am not blokcing anything on my system