Join 34,000+ subscribers and receive articles from our blog about software quality, testing, QA and security.
 

Email Notification does not work and returns an authentication error


#1

Configured in testrail, email exchange server details of our company and tried sending test email but it fails with below error.

Sending the test email failed. Please see the following messages and server output for details: No authentication mechanisms were tried since the server did not support any of the ones loaded. Loaded authenticators: [CRAM-MD5, LOGIN, PLAIN]

Note: Our email exchange server supports AUTH GSSAPI NTLM LOGIN

Please let me know .


#2

Hello,

It appears that your Exchange server doesn’t support the SMTP authentication / encryption methods of TestRail. The easiest way to integrate TestRail in this case (without having to change your Exchange server configuration) would be via a simple SMTP forwarding service installed on your TestRail server.

IIS has support for a simple SMTP service which you can install locally on the TestRail server. I would recommend setting this up to forward all emails to your original Exchange server (using the authentication method it supports, if needed). The following tutorial explains the basic idea behind this concept and how to configure this:

I hope this helps and please let me know in case you have any questions.


#3

Hi Tobias,

I tried the solution you gave but still same issue.

Regards,
Venkata.


#4

Hi Venkata,

Could you share a few more details on what you see? The local IIS SMTP forwarding service is usually a good choice if you have specific requirements for sending emails (such as Exchange authentication) and this solution is used by many customers and works well in our experience.

Regards,
Tobias


#5

Hi Tobias,

Testrail system log when test email is sent is below:

09:35:04	[Swift_ConnectionException] No authentication mechanisms were tried since the server did not support any of the ones loaded. Loaded authenticators: [CRAM-MD5, LOGIN, PLAIN]

at Swift_Connection_SMTP->runAuthenticators (SMTP.php:332)
at Swift_Connection_SMTP->postConnect (Swift.php:265)
at Swift->handshake (Swift.php:221)
at Swift->connect (Swift.php:102)
at Swift->__construct (email.php:120)
at Email_library->_try_send (email.php:78)
at Email_library->send (email.php:117)
at email::send (notifications.php:110)
at Notifications_job->_send_message (notifications.php:65)
at Notifications_job->_process_message (notifications.php:52)
at Notifications_job->run (tasks.php:161)
at Tasks_controller->_run_job (tasks.php:130)
at Tasks_controller->_process_job (tasks.php:61)
at Tasks_controller->_run (tasks.php:50)
at Tasks_controller->index (controller.php:82)
at Controller->_invoke_cli (controller.php:72)
at Controller->_invoke (gizmo.php:107)
at require_once (index.php:106)
at require_once (task.php:47)

I don’t see any error log in the server where SMTP forwarding service is configured.


#6

Hi Venkata,

Thanks for the additional details. I would recommend testing the SMTP forwarder outside of TestRail first and then configuring the service in TestRail once you got it working. TestRail supports all standard SMTP authentication features but it might be needed to enable the authentication modules on the SMTP forwarder side first. You would also need to make sure to update the email settings in TestRail to point to your SMTP forwarder.

Regards,
Tobias


#7

Hi Tobias,

Thanks for the inputs. The issue is with configuration of email settings in test rail. I was pointing to remote SMTP server IP address instead of local server IP address where SMTP forwarder service is configured. After changing the IP to local IP then it started working.

Thanks a lot for your on time support.


#8

That’s great to hear, Venkata, and you are welcome!

Regards,
Tobias