Subscribe Join 180,000+ subscribers and receive articles from our blog about software quality, testing, QA and security. Subscribe

Dynamic Test Case Filtering not working for Sections

I’m trying the new dynamic test case filtering. My usage was to set a single section (i.e. test case folder) so that any new tests added to that section automatically appear in my test run. I assumed this was the intended behavior of this feature. But when I add a test to the folder my test run never updates its test cases.

Hi @asher - you can accomplish this by setting the filter to your desired sections, rather than selecting them specifically using the checkbox approach.

See the docs here for more info: Dynamic Filtering

I did set the filter. Then I clicked Set Selection (which then auto-checked the checkboxes). I also tried setting the filter without Set Selection but then nothing gets chosen and I can’t save the test run.
I recorded this behavior but don’t want to post that in the forum. I can send it directly to you if you want to see what I’m doing.

Hi Asher - sure, send me the details and we can take a closer look.


asher

    March 3

I did set the filter. Then I clicked Set Selection (which then auto-checked the checkboxes). I also tried setting the filter without Set Selection but then nothing gets chosen and I can’t save the test run.
I recorded this behavior but don’t want to post that in the forum. I can send it directly to you if you want to see what I’m doing.


Visit Topic or reply to this email to respond.


In Reply To


sjpknight
Gurock Team

    March 2

Hi @asher - you can accomplish this by setting the filter to your desired sections, rather than selecting them specifically using the checkbox approach. See the docs here for more info: Dynamic Filtering


Visit Topic or reply to this email to respond.

To unsubscribe from these emails, click here.

Cheers,
Simon

Simon Knight

Product Manager

E: simon.knight@gurock.io

M: +44(0)7775676227

Hi Simon,

Here’s a loom video showing what I’m trying to do. Let me know if this is user error / mis-undertsanding or if the feature isn’t behaving correctly.

Edit Test Run - TestRail - Watch Video

Thanks for getting back to me!

Asher Cornelius

Sr. Product Manager

sampleserve_dot_com

Hi @asher - I’ve attached some video demonstrating the dynamic filter functionality adding a new case to a filter defined by section. Hopefully this helps you, but please do let us know if you have any further questions or issues!

Test Runs & Results - TestRail — Watch Video

Hi Simon.

Thanks for the video. I replicated your steps exactly, and the first I did it the dynamic selection didn’t work. After I created a new test in the desired folder (just like you did on the video) it changed my test run setting from ‘Dynamic Filtering’ to ‘Select specific test cases.’ I didn’t capture that on a recording :frowning: However, on subsequent attempts the filtering all performed as expected. So for now I’ll roll with it (I understand it’s beta) but I wanted you to have the feedback.

Thank you getting back to me on this. I appreciate the customer focus.

Asher

Hi Simon,

Is it possible to click just the parent section in the filter settings and it could include all the subsections in the test run?
Right now we need to choose all the subsections in the filter settings, but once there’re too many subsections, it will return an error “Field Dynamic Filters is too long (250 characters at most).” after set the filter.

Thanks,
Olive

1 Like

I’m also getting this “250 characters at most” issue.

I’ll add my review, if possible, I would like that when choosing a filter on the parent section, all the child sections added too, and not just the cases of the parent, get into the filter.

Hello everyone, thank you for the feedback.

@olivedq and @lcorrigan - I’d like to get a little more information about the issue you’re having. I’ve attempted to replicate this by using the dynamic filtering option, then manually selecting each of my sections in the filter settings, but I’m not seeing the error when setting my selection. Are there any additional filters also being applied? Also can you let me know the approximate number of sections that are being selected when the error appears?

If you can provide us any additional details about when the error is triggering (when hitting the “set selection” button, when finalizing the test run, etc. and how many selections you’re making in the filtering I’ll be happy to make sure this gets reported to the development team.

@jacob.scott, I found I can re-create this without using any other filter aspects than the section filters. I was using 43 sections/folders selected. I was able to make the error with only 30 sections selected. Ironically, had I been able to just select top-level sections, it would have factored out to only two. I don’t get the error if I’m doing this for a test run within a Test Plan, but I’m getting other problems there. Issue with Dynamic Filtering for Test Runs within Test Plans.