Subscribe Join 180,000+ subscribers and receive articles from our blog about software quality, testing, QA and security. Subscribe

Dynamic Filtering not working for Configurations within Test Plan

If I create a standalone “Test Run” and add a dynamic filter to it (I am using a custom field called “Applicable Stream Types” = Linear) - Then the filter works fine, the new test cases fulfilling this criterion get added automatically.

But if I create a Test Plan and a Test Run within it, add configurations (browsers in this case) - add the dynamic filter to the Test Run (again “Applicable Stream Types” = Linear); then the new test cases fulfilling this criterion do not get added automatically. I have to re-run the filter.

Seems like there is a bug in the dynamic filter if configurations get added to the test run?

@rituvirdi

Hi,

Welcome to the community and thanks for your post. I just checked in the log. We have an open bug on this and our team is working on its fix.

Sorry for the inconvenience caused.

Thanks,
Shanu

Hi Shanu,

Here are the steps to reproduce.

  1. Create a Test Plan
  2. Add a Test Run to it.
  3. Now add some Configuration to the Test Run (Like different browsers, Safari, Chrome etc)
  4. On the Test Run, dynamic filter - select some filter option. Like if you have a Test Type Field with options Sanity and Regression, choose only Sanity and apply this filter.
  5. The first time you apply this filter, the configurations update to reflect the right number of test cases (same as the Test Run as expected).
  6. Now add a test case to the test suite you have and set the type as sanity.

Expected Result is that the Test Run and Configurations pick up this new test case automatically.

But currently, they don’t update automatically. You have to go to the Test Run, apply the filter again manually and then the counts in the Test Run and Configurations get updated.

If you don’t have any configurations, then the Test Run updates the test case count automatically.

Hope this helps. Let me know if you have any questions. I really wish this gets resolved quickly. It is no fun to keep doing this manually every time a test case gets added. :slightly_frowning_face:

Regards,
Ritu

Hello,

Any updates on this? Can you share the link to the open bug you mentioned above please?

Regards,
Ritu

Their bug lists are not public.

As mentioned by @BGanger, we do not have a public bug status report as of now. However, you can stay up to date on the latest feature releases on our blog -

Let me know if this helps !

Regards,
Shanu