Join 34,000+ subscribers and receive articles from our blog about software quality, testing, QA and security.
 

Defect integration with Jira


#1

I have been able to set up the integration for a new project to JIRA. However when adding a test result and selecting PUSH to enter a defect, the projects that come up don’t include the one that I have just added. I can’t see how to add that new project so it will come up as a selection in the drop down window


#2

Hello,

Thanks for your posting. TestRail pulls the list of projects directly from JIRA and if the list doesn’t include all (expected) projects, then this is likely a permission setting/issue in JIRA. Could you please check if your JIRA user account has access to this project in JIRA?

Cheers,
Tobias


#3

Thanks for the information. That was the issue.


#4

Great to hear that, glad to help :slightly_smiling:

Cheers,
Tobias


#5

I am getting the following error trying to integrate Testrail with Jira’s Defects

		An Error Occurred		
	Plugin "Jira_REST" returned an error: Could not resolve host: <your-server>

#6

Testrail log:

[E] 2016-05-18 15:51:02 [3606ms]: [HttpException] Could not resolve host:

Details:
File: /var/www/html/testrail/sys/helpers/ex.php
Line: 25
Status Code: 500
Host: testrail.dts.com
Uri: /testrail//index.php?/defects/ajax_lookup (POST)

Browser: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:46.0) Gecko/20100101 Firefox/46.0
PHP: 5.5.9-1ubuntu4.14
Server: Linux 3.13.0-76-generic #120-Ubuntu SMP Mon Jan 18 15:59:10 UTC 2016 x86_64

project_id: 3
defect_id: 2638
_token: 3fgyzQiA8D09Biu7h9yC
_version: 5.1.0.3413

Trace:
at ex::raise (http.php:219)
at http::request_ex (Jira_REST.php:1481)
at Jira_REST_api->_send_request (Jira_REST.php:1444)
at Jira_REST_api->_send_command (Jira_REST.php:1438)
at Jira_REST_api->get_issue (Jira_REST.php:805)
at Jira_REST_defect_plugin->lookup (defects.php:1126)
at Defects_controller->ajax_lookup (:)
at call_user_func_array (controller.php:254)
at Controller->_invoke_web_call (controller.php:167)
at Controller->_invoke_web (controller.php:119)
at Controller->_invoke (gizmo.php:107)
at require_once (index.php:106)


#7

Hi German,

Thanks for your posting! This means that TestRail cannot connect to your JIRA installation and it seems to be a DNS issue (host name lookup). For the full lookup/push functionality, TestRail needs to use JIRA’s API and this requires a direct connection between TestRail and JIRA. Is JIRA reachable from the TestRail server? Can you try to use the IP of the JIRA server instead of a host name (address option under Administration > Integration)?

Cheers,
Tobias


#8

Hi Tobias,

Thank you for the response, my issue is solved I had mis-configured URL address.

Regards,
German


Integrating TR with JIRA
#9

Happy to hear that it’s working :slight_smile:

Cheers,
Tobias