Join 34,000+ subscribers and receive articles from our blog about software quality, testing, QA and security.

Database update issue After upgrading to TestRail


We have updated our testrail from 5.4 to Version.

The installation looks fine and while moving to the db upgrade wizard we are getting error .

Installation Status

|TestRail version :

|Your database version :185
|New database version:188
|Checking installation files :Success

TestRail Update Wizard
Please see below for the result of the update and the next steps.

Updating to database version 186 Error (details below)
**Updating to database version 187 **
**Updating to database version 188 **
Duplicate column name 'is_reset_password_forced’


Hi Krishnakumar,

Thanks for your post! We would need a bit more information about your TestRail installation to help troubleshoot the error. Could you please send an email directly to so we can gather these details and provide the next steps? Specifically, if we could get more details about the operating system and version you’re using, as well as the TestRail logs from the day you attempted to upgrade, this would be helpful.

We look forward to your email!



Hi There,

I’ve send a mail to mentioned mail ID. But still not received any update.

we are awaiting for your response.



We have faced the same Duplicate column name 'is_reset_password_forced error at database Up gradation to version 186 for Testrail



Hello Krishna,

We’ve received your email and will continue to troubleshoot and update you via email. I’m also happy to update this thread once we’ve determined a solution in case it is useful for other customers as well.



So I ran into this issue as well. Went through all the upgrades via gui and was able to log in and use that app fine. Upon next login it asked me to upgrade again stating that update 186 - 188 needs to be applied. Upon hitting next I received:

With a schema update, my only way forward was to rollback the DB which is something I dont take lightly. I found a work around by doing the following:

:warning:Use this at your own discretion, I am just mentioning what worked for me:warning:

  1. ssh into the testrail application server
  2. Navigate to the testrail installation db folder (for me it was /var/www/testrail/db/mysql/)
  3. edit 186.php, comment out lines 3-5.
  4. edit 187.php, comment out line 3.
  5. php /var/www/testrail/run.php update
  6. login and test the app.


Thank you for your post and steps to your resolution! @paulweston
I’m glad you were able to resolve this on your end. We’re still looking into the cause of this issue and your reply is likely to help with our investigation.

Thank you for also mentioning the following:

This is important to note as we do not yet have an official cause/resolution at the moment. As soon as we have additional information we’ll update this forum promptly.


I went ahead and updated prod from 183 to 188. I waited a bit longer after servers came up, I also used the cli updater. I was able to upgrade to 188 with no issues.


We are facing the same problem during upgrade to
Can you please let us know the resolution for this.

TestRail Update Wizard
Please see below for the result of the update and the next steps.

Updating to database version 186 Error (details below)
Updating to database version 187
Updating to database version 188
Duplicate column name ‘is_reset_password_forced’
Please return to the previous wizard page to adjust your settings and try the update again. If you are unsure on how to solve this problem, please contact the Gurock Software support. Please make sure to include the full error message in your support request.


@pbandari, we have managed to upgrade Testrail to v5.5.1.3746.

Steps which @paulweston mentioned didn’t worked for us. Its was failing at some point.

Adding the steps below.

  1. Take DB back up & confirm there is no column with name ‘is_reset_password_forced.
  2. Place the files and validate ioncube.
  3. Start the upgrade.
  4. Once the error has came, Do not click / refresh any thing on the screen .
    check the DB table has column with name ‘is_reset_password_forced.
    if yes,
  • Remove the column
  • Replace the entire Testrail file.
  1. Click on previous button on the upgrade screen & continue the process.

Please keep posted if it worked for you :grinning: .