Subscribe Join 180,000+ subscribers and receive articles from our blog about software quality, testing, QA and security. Subscribe

Clicking on a Test Plan, Milestone gives an error- undefined index: email

Hi All,

I’m trying to demonstrate Testrail to my team as we need to select it as the Test Management Tool. But suddenly it stopped working once I clicked on Test run, Test case, Milestone and etc. Giving the following issue.
I tried creating a new Testrail trial account and still getting the same error.

My testrail server URLs as below. I have a 14 days trial testrail server.

Hi @isuruuy - this issue is most likely related to the configuration of your GitHub plugin. Follow the instructions in the release announcement (also below for reference) to fix the issue:

Updating Your Plugin

With this new release, teams who are interested in using the new functionality may need to reset their plugin configuration. The steps are simple, but must be performed by an administrator:

  1. Navigate to the administration area for global integrations (or project settings for project-level integrations)
  2. Copy your existing connection settings into a temporary text file, sticky note, etc.
  3. On both the Defects and References tabs, change the plugin to the blank value at the top of the list
  4. Save your settings
  5. Go back to the Defects and References tabs and choose your tool
  6. Copy your connection settings values back into the plugin settings.
  7. Save your integration settings.

This will set your plugin with a default configuration, allowing you to make further changes if desired.

Cheers,
Simon

I am having the same error. I tried the solution for updating the gitHub plugin. I am having the same results after. Has it worked for anyone?
I can get into the ToDos and Reports, but no Milestones, Test Runs or Test Plans for any of my projects.
We are on a TestRail Professional Cloud account.

Hi @mspacman - does your config now have an email parameter?

email=your GitHub email address

If so, I would not expect to be seeing the “undefined index: email” error still… Please can you confirm that’s what you’re still seeing?

no, it’s setup with my git user name and token.

Ok @mspacman - so if you add an email parameter per my response above, that should resolve the issue.

i added the email parameter after my user and password parameters. no changes in results.

Yes this workaround worked for me.

Good to hear @isuruuy - @mspacman if you’re continuing to experience difficulty, after following the steps above, please can you send an email to contact@gurock.com so we can look into the situation further for you?

Thanks,
Simon

I did as below. Did not add any parameter for the email and username once reloaded the plugin.

; Please configure your GitHub connection below.
; Note: requires GitHub API v3 or later. You
; can alternatively specify a GitHub Enterprise
; server address.
[connection]
address=https://api.github.com/
user=githubusername
password=githubpassword
email=
username=

[repository]
owner= owner
name=qa-artifacts

[push.fields]
summary=on
milestone=on
assignee=on
label=on
description=on

[hover.fields]
summary=on
milestone=on
assignee=on
label=on
description=on

I got it to work. Thanks for all the help. I had to do it for all configurations - global and each project’s individual before i could get into Test Cases/Plans for any of the projects. :slight_smile:

1 Like