Join 34,000+ subscribers and receive articles from our blog about software quality, testing, QA and security.
 

Cannot find Configurations


#1

Hi,

I just signed up for a new TestRail trial account and now wanted to set up a project. But I cannot find the configurations (different operating systems for example) as shown in this video http://www.gurock.com/testrail/videos/test-plans-configurations/ anywhere.
Also there is nothing about “Test Suites” in the menu. I’m logged in as the single user that was created when signing up. I suppose this user should have all the “admin” rights for the new project?

Thanks,
Klemens


#2

Hi Klemens,

you will only see the configurations (for different OS e.g.) once you setup a test plan and link test cases to it.

Test Suites are set up in the tab “Suites & Cases”. After the suites are set up you can set up a test run or test plan, which contains one (run) or more (plan) test suites.
Your user should have at least “designer” or “lead” user rights to do so.


#3

Hello Klemens,

Thanks for your posting. Test plans and configurations can be managed on the Test Runs & Results tab via the Add Test Plan in the sidebar. After clicking on this button, you are redirect to a new, empty test plan form and can add the test runs from the sidebar (via the Add Test Run button). You can then manage the configurations via the Select Configurations button.

I hope this helps!

Regards,
Tobias


#4

Hi Tobias

I also tried to work with configurations but the box is empty after clicking on the “select configurations” button.
Where do you set up the list of configurations you could choose?

Thanks

Stephanie


#5

Thanks, I found it.

@spacefrog: I have no “Suites & Cases” tab, just “Test Cases”.

@Stephanie: I think you need to click the “Add Group” link below the empty box to add configurations. At least that’s what I did. But I’m not an expert… :wink:


#6

There is no button to add a group in box in the version 3.1.3.3146

I see it with version 4.0 but I do not understand why you have to get a group before selecting a configuration.


#7

Hello Stephanie, Klemens,

You would need to click the Add Group link on the Select Configurations dialog as Klemens mentioned to add a configuration group (e.g., “Web Browser” or “Operating Systems”). You can then configurations under this group with the Add Configuration link (e.g. “Firefox”, “Internet Explorer 11”, “Google Chrome”).

Klemens: I assume you’re successfully using the configuration feature by now, is this correct? Please let me know if this is not the case or if you have any further questions.

Regards,
Tobias


#8

Hi
We have now the last version of TestRail.
However in one project, I cannot see the AddGroup link to add configurations in my test run.
What does trigger the displaying of the AddGroup link?

Thanks

Stephanie


#9

Hello Stephanie,

Thanks for your posting. You can select and manage the configurations on the test plan form (Test Runs & Results > Add Test Plan) after adding one or more test suites. You should then see a “Configurations” button which allows you to select and manage the configurations.

Please review the following training video on test plans and configurations for details:

http://www.gurock.com/testrail/videos/test-plans-configurations/

(the selection of the configurations is slightly different with the 4.0 and the video still shows the previous version, but the idea is the same)

I hope this helps and please let us know in case you have any further questions.

Regards,
Tobias


#10

Hi

I know how to add configurations, what I do not have with one project is the link named “AddGroup” to be able to add configurations.

Is there a specific set up to trigger the “AddGroup” functionality?

Thanks

Stephanie


#11

Hello Stephanie,

Thanks for your reply. If you don’t see the “Add Group” link on the Select Configurations dialog, you don’t have the permissions to add/edit or delete configurations (maybe just for this project). Please contact your TestRail administrator to check this.

Regards,
Tobias


#12

Right, it was a permission issue. I changed it and it fixed it.

Thanks a lot Tobias!


#13

You are welcome, Stephanie!

Regards,
Tobias