Join 34,000+ subscribers and receive articles from our blog about software quality, testing, QA and security.
 

Cannot create multiple test suites as admin


#1

Hello.

We have a standalone (server) TestRail v5.4.0.3659.
For some reason user with admin persmissions cannot create a new test suite as there is not any button (Add Test Suite or something) on Test Suites & Cases.

The project I’ve been trying to create new test suites is just empty new one type of Use multiple test suites to manage cases.
I tried to create a new test suite for the project under the same admin user via REST api but got HTTP 403("You are not allowed to add test suites (insufficient permissions).

We have an existing project with the same type which has 5 test suites and lots of test cases but the issue is the same, it’s not possible to add a new test suite.
It’s obvious there was Add Test Suite button before as this project contains 5 test suites already.

How can I add a new test suite for the existing project?

Thank you for your help!

Regards,
Mansur


#2

You need to look at the Role assigned to the user. Administrator is a separate setting and Roles are used to determine permissions at the Project level.


#3

Thank you for the reply, now it works. Big thanks!


#4

Your welcome, glad to help…