Join 34,000+ subscribers and receive articles from our
blog about software quality, testing, QA and security.

Bug in adding new field


#1

So what I did I actually added system field ‘preconds’ to test results window, so every time TC is executed, all info was on 1 screen. Of course it didn’t work. So I tried to remove it

ER: field is removed
AR: see the attachment(it is constantly being removed for more then an hour), I’ve tried to reload the page


#2

Hello Volodia,

Thanks for your post! This wouldn’t be a bug as the built-in Preconditions field is a Case field and not a result field (and this can’t be moved/changed to a result field). So this is likely just a new custom Preconditions field that you’ve added as a Result field, however the field was attempting to install and possibly stuck at this point. This can happen if you don’t have the background task configured properly (as adding a new field is managed by TestRail’s background task), or if some other error occurred when attempting to create the field (e.g. if your database ran out of resources or hit another unexpected error). We’re happy to help troubleshoot the issue, and we would just need to retrieve some more details. Can you send an email directly to contact@gurock.com with the issue that you’re experiencing, and we can request some additional logs and database details to help provide the best recommendation?

We look forward to your email!

Regards,
Marco