Join 34,000+ subscribers and receive articles from our
blog about software quality, testing, QA and security.

Backlog issue in SmartInspect Router



I am trying to evaluate the SI Router application. But I am having some difficulties in configuring the backlog feature; otherwise everything else is working as expected.

If I have the following settings for the Router:

<router xmlns=""> <logging level="warning" /> <listeners> <tcp ip="" port="4229" /> </listeners> <routes> <route> <triggers> <application/> </triggers> <connections>file(filename="logs\%appname%-backlog.sil", backlog.enabled="true")</connections> </route> <route> <connections>file(filename="logs\backlog.sil", backlog.enabled="true")</connections> </route> <route> <connections>tcp(backlog.enabled="true")</connections> </route> <!-- This works as expected --> <route> <connections>file(filename="logs\log.sil")</connections> </route> </routes> </router>

And the following test application, that I am running on the same machine as where the Router is running:

[code]static void Main(string[] args)
ConnectionsBuilder builder = new ConnectionsBuilder();
builder.AddOption(“port”, “4229”);
SiAuto.Si.Connections = builder.Connections;
SiAuto.Si.AppName = “ClientApplication1”;
SiAuto.Si.Enabled = true;

SiAuto.Main.LogMessage("Log Message");
//This should flush the backlog queue
SiAuto.Main.LogError("Log Error");

SiAuto.Si.Enabled = false;


Then only the log.sil file gets created, correctly containing the two log entries. All the other connections, that include the backlog option, are not routing any log message, neither to the Console(through the tcp connection) or to the specified files.

So is this not supported, or am I doing something wrong in my setup?

I am running SmartInspect version



Hello Hallur,

Thanks for your posting. This actually looks correct to me and should work as expected. Could you please try your routes without the backlog option to check if the routes work in general? You can also enable logging for the Router service itself so we can further diagnose this issue:

<?xml version="1.0" encoding="utf-8" ?> <router xmlns=""> ... <logging level="debug" /> ... </router>

(the log files are placed into the app data directory of the Router, e.g. C:\Users\LocalService\AppData\Roaming\SmartInspect\Router)

Thanks again and I look forward to your reply.



Hi Tobias,

All the Routes work as expected when I remove the backlog option.
I have changed the Router config to this:

<router xmlns=""> <logging level="debug" /> <listeners> <tcp ip="" port="4229" /> </listeners> <routes> <route> <connections>file(filename="logs\backlog.sil", backlog.enabled="true")</connections> </route> </routes> </router>

And below is the generated Trace Log from the Router after a single run of my test application.



Hello Hallur,

Thanks for the additional details and the log file. We will look into it and get back to you as soon as possible. Please let me know in case you have any questions in the meantime.



Hello Hallur,

We’ve analyzed this now and the backlog option is not supported on the SmartInspect Router as the log levels (which are used by the backlog feature) are a client-side feature only and are currently not transmitted to the Router. Sorry that I don’t have better news but please let me know in case you have any questions.