Join 34,000+ subscribers and receive articles from our blog about software quality, testing, QA and security.
 

API + multi-select broken? - Resolved


#1

Hey TestRail team,

We are trying out the API with our testrail installation and are running into problems with multi-select fields. We are doing a simple get_case and are running into this error:

{“result”:false,“error”:“Unknown column ‘custom_product_mutliselect’ in ‘field list’”}

Any suggestions?

Thanks.

-Will


#2

Looks like this was an error in our setup. We did not have the current API installed. It is working now with the current API.


#3

Hello Will,

Thanks for your posting. Yes, you need the current version of the API for TestRail 2.7 (v14).

Regards,
Tobias