Join 34,000+ subscribers and receive articles from our blog about software quality, testing, QA and security.
 

An Error "Start tag expected, '<' not found" on importing CSV file


#1

Hi - I am trying to import the XML file which I created using your script (http://docs.gurock.com/testrail-admin/migration-csv), I was able to successfully run this script and it created the xml file as well, but when I try to import the xml it gives “Start tag expected, ‘<’ not found”

I then tried to create the xml from the testdata.csv which is given in Simple directory of your testrail-migrate-csv-1.2.zip file, it created xml file and the same error was shown when I tried to import this xml file.

I then tried to export some test cases from one suite and it created an xml file, I then tried to import this xml file and it gave me the same error

I have concluded that your script to convert csv file to xml file is working fine but it seems that the import functionality has some issues, Please look into it on urgent basis.

Thanks,
Ravi


#2

Hello Ravi,

Thanks for your posting. I believe we are already in contact via email with you regarding this issue, is this correct?


#3

I ran into this same problem as the original poster. What I found interesting was this issue only occurs with Mac. When accessing your site with a Windows machine and importing the csv file it does so with no problem. Was there another solution offered to Ravi that is different from mine?


#4

Hi Geo,

Thanks for your posting. Did you see the same error message "Start tag expected, ‘<’ not found”? This is actually an XML import error (if you try to import a non-XML file). Are you sure that you used the CSV and not XML import? Or did you see a different error message?

Cheers,
Tobias


#5

I ran into this error just now on my Mac 10.11+ (El Capitan) trying to upload a .csv file


#6

Hi Tony,

Thanks for your feedback. For CSV files, you would need to use the CSV import and the error message “Start tag expected …” is an XML import message (if you try to upload a non-XML file).

http://docs.gurock.com/testrail-userguide/howto-import-csv

I hope this helps!

Cheers,
Tobias


#7

Thanks Gurock Team, but no - that does not help.

I have downloaded the test file for the product and tried to incorporate that into the Joomla installation with the same results, I even cut and pasted the information into Notepad++ and saved it as ASCII and no bueno.

What is going on with the product that it don’t understand that it is CSV and not XML?


#8

Hi Matt,

Thank you for the post. In this case would you mind sending an email to contact@gurock.com with a description of the issue you are having? Also if you can include any relevant attachments, i.e., screenshots, etc. that would be helpful as well. You can call out my name in the ticket as well.