Join 34,000+ subscribers and receive articles from our blog about software quality, testing, QA and security.
 

Alert- Script tried to disable memory_limit


#1

I’ve added the cron task as per the instructions on your website, and noticed our syslog is now logging an error every minute:

Jul 25 10:34:01 Rail suhosin[6821]: ALERT - script tried to disable memory_limit by setting it to a negative value -1 bytes which is not allowed (attacker ‘REMOTE_ADDR not set’, file ‘unknown’)

I presume it can be ignored, but seems a bit ‘noisy’. Or is this something else entirely?
The error in the logs only have appeared since the cron was updated.


#2

Hi Chris,

Our background task script is trying to increase the memory limit for the script execution so it doesn’t run into any default memory limitations. This is usually not a problem as the script is executed locally anyway (like any other process), but it appears that your PHP installation is blocking this request. Your PHP configuration is using the suhosin hardening/security patch(es) and this is not uncommon, but we haven’t seen it blocking the memory limit request so far. Could you let me know how you’ve installed PHP? Was it through a package of your Linux distribution and if so, which distribution and version is it?

You might be able to disable the limit by adding the following to your PHP.ini file:

suhosin.memory_limit=-1

I’m not sure if -1 is an acceptable value for suhosin though. Another option would be to set the memory limit to -1 in the PHP.ini file (especially if you are using a separate configuration for command line PHP):

memory_limit=-1

Just let me know if you still see issues with this and we might be able to include a configuration setting for this in TestRail’s configuration file for an updated version.

Thanks,
Dennis