Join 34,000+ subscribers and receive articles from our blog about software quality, testing, QA and security.
 

404 Errors with Reports - RESOLVED


#1

I’m getting 404 errors when trying to view reports. They used to work and the reports exist in the filesystem, and apache has correct perms and ownership. Any ideas?

Report file or resource not found
---
Details: <missing>
File: /var/www/html/testrail/sys/helpers/ex.php
Line: 25
Status Code: 404
Host: host.server
Uri: /testrail/index.php?/reports/render/60 (GET)
---
Browser: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/68.0.3440.106 Safari/537.36
PHP: 5.3.x
Server: Linux 2.6.x
---
Trace:
at ex::raise (ex.php:25)
at ex::raise (ex.php:77)
at ex::raiset (reports.php:399)
at Reports_controller->_stream_file (reports.php:350)
at Reports_controller->render (controller.php:257)
at Controller->_invoke_web_call (controller.php:168)
at Controller->_invoke_web (controller.php:120)
at Controller->_invoke (gizmo.php:107)
at require_once (index.php:106)
---
Version: 5.4.0.3659

#2

I’m having the same issue but at Trace: Reports_controller->render (:)

any help will be appreciated!


#3

Please send a support request to contact@gurock.com if you’re still experiencing problems.

Cheers,
Simon


#4

Already have and still working with them. No resolution thus far.


#5

Problem was SELINUX related. Either turning SELINUX off or adjusting the context of the files in the reports directory resolved the issue.